Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Virtual Machine instalation for "Mining the Social Web" is not working

I followed the instructions to install the Virtual Machine used in the
book: "Mining the Social Web: Data Mining Facebook, Twiteer, LinkedIn, Google+, GitHub and More". I tried in OS X and Windows, but I could not install the VM successfully, because I got the same error message: Vagrant failed to execute the capability 'chef_install'.
1 person has
this question
+1
Reply
  • Hi Sandro,

    Please see this page on Github for the solution to that problem -
    https://github.com/ptwobrussell/Minin...

    Best regards,
    Chris Olson
    O'Reilly Customer Service
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly

  • I’m frustrated
    @Chris I followed the instructions, but they didn't work either. Here follows the new error message. I'm using windows 8.1 Enterprise.

    ==> default: STDERR: /usr/local/lib/python2.7/dist-packages/pip/_vendor/requests
    /packages/urllib3/util/ssl_.py:318: SNIMissingWarning: An HTTPS request has been
    made, but the SNI (Subject Name Indication) extension to TLS is not available o
    n this platform. This may cause the server to present an incorrect TLS certifica
    te, which can cause validation failures. You can upgrade to a newer version of P
    ython to solve this. For more information, see https://urllib3.readthedocs.org/e
    n/latest/security.html#snimissingwarning.
    ==> default: SNIMissingWarning
    ==> default: /usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/package
    s/urllib3/util/ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is
    not available. This prevents urllib3 from configuring SSL appropriately and may
    cause certain SSL connections to fail. You can upgrade to a newer version of Py
    thon to solve this. For more information, see https://urllib3.readthedocs.org/en
    /latest/security.html#insecureplatformwarning.
    ==> default: InsecurePlatformWarning
    ==> default: Command "python setup.py egg_info" failed with error code 1 in /tmp
    /pip-build-kkDXWM/boilerpipe/
    ==> default: ---- End output of pip install boilerpipe==1.2.0.0 ----
    ==> default: Ran pip install boilerpipe==1.2.0.0 returned 1
    ==> default: [2016-09-09T15:05:23+00:00] FATAL: Chef::Exceptions::ChildConvergeE
    rror: Chef run process exited unsuccessfully (exit code 1)
    Chef never successfully completed! Any errors should be visible in the
    output above. Please fix your recipes so that they properly complete.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly