Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

Filemaker Import Field Mapping in the Stone Age

In Filemaker Pro 9 Missing Manual: the book states (page 658) that the order of the Source Fields will appear "in the order in which they appear in the file that you're importing." Not true. I took a copy of the source file and removed all layouts, created a new layout in which the fields are listed by alpha, went to "Manage Database" field window and listed them there by alpha, closed the file and then went to import them in the target file. The source fields continue to show in the Import Field Mapping window in random order. Is there no way to fix this?
1 person has
this question
+1
Reply
  • Hi Fred,
    sorry for the delay in responding to you. I'll get your question over to our book tech staff so that they can take a look at your issue.
    You can contact them directly at:
    booktech@oreilly.com.

    Cheers,
    Tai Hake
    Customer Service Rep,
    O'Reilly Media
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned

  • Hi Fred,

    The authors responded to your question with the following:

    Fred:

    If you're importing from an Excel spreadsheet, a text based file format like CSV or Tab Delimited Text, or many of the other formats FileMaker supports, the fields will indeed be in the order they are in the file.

    It sounds like you're importing from another FileMaker Pro database, in which case the phase "in the order they appear" is probably misleading. FileMaker fields don't really have any order, per se, because you can arrange them however you want on any particular layout. I believe the order they're listed when you import is the original order the fields were created. As far as I know, there is no way to change this directly, and it is indeed frustrating.

    One workaround is to do this:

    1: Open the FileMaker file you want to import FROM
    2: EXPORT the records to a new FileMaker file, specifying a field export order that makes sense to you.
    3: IMPORT the file you exported into your final database. Now the fields will be listed in the order you specified when you exported in step 2.

    You can even set up a script in your database to export the fields in the order you want if you have to do this frequently.

    Hope it helps,

    Geoff Coffey
    ===========

    ------------Addendum from Susan Prosser-------------

    The only thing I'd add is that when you're going from FileMaker to FileMaker it's sometimes easier to change the names of the fields in your source table so you can use the Matching Names option to bypass the hassle of field mapping. It's tedious to set up, but super useful if you have to do repeated imports.

    Plus it's a little less brittle than a custom field order. In a repeating import, you may have to add new fields to both the source and target tables as your needs change. But unless you create all the same fields in both files, and in exactly the same order, the two files will get out of sync and your import will break. At least Matching Names doesn't depend on an artificial order but on a match between field names.

    Best of luck and hope this is helpful,
    Susan Prosser
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned